Entri is a DNS and domain management platform built for SaaS companies. Incident history and uptime data reflect the performance of our core infrastructure and partner integrations. For API documentation and integration guides, visit our developer docs at https://developers.entri.com.
Let's Encrypt has completed its scheduled maintenance and certificate issuance is back to normal on Entri Power and Entri Secure. Any certificates that were delayed during the window will be issued automatically; no action is needed on your side.
Resolved
Let's Encrypt has completed its scheduled maintenance and certificate issuance is back to normal on Entri Power and Entri Secure. Any certificates that were delayed during the window will be issued automatically; no action is needed on your side.
Identified
Our certificate provider, Let's Encrypt, is performing scheduled maintenance on its production systems today, September 2, from 20:30 to 22:30 UTC. During this window, new SSL certificate issuance and renewals for Entri Power and Entri Secure may be delayed or fail temporarily. Existing certificates and live sites are not affected. We are monitoring the situation and will post an update once the maintenance is complete.